#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?P<c>[+-]? *\d*(?:\.\d*)?) *\*? *[xX] *(?:\^ *(?P<e>[+-]? *\d*(?:\.\d*)?))?"
Local $sString = "y=x+3.3X^-50+ 15x25.5 - 4x^+2x^2 +3*x-2.5+1.1" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")