using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?P<c>[+-]? *\d*(?:\.\d*)?) *\*? *[xX] *(?:\^ *(?P<e>[+-]? *\d*(?:\.\d*)?))?";
string input = @"y=x+3.3X^-50+ 15x25.5 - 4x^+2x^2 +3*x-2.5+1.1
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}