const regex = new RegExp('(?P<c>[+-]? *\\d*(?:\\.\\d*)?) *\\*? *[xX] *(?:\\^ *(?P<e>[+-]? *\\d*(?:\\.\\d*)?))?', 'g')
const str = `y=x+3.3X^-50+ 15x25.5 - 4x^+2x^2 +3*x-2.5+1.1
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}