$re = '`(?P<c>[+-]? *\d*(?:\.\d*)?) *\*? *[xX] *(?:\^ *(?P<e>[+-]? *\d*(?:\.\d*)?))?`';
$str = 'y=x+3.3X^-50+ 15x25.5 - 4x^+2x^2 +3*x-2.5+1.1
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);