package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?P<c>[+-]? *\d*(?:\.\d*)?) *\*? *[xX] *(?:\^ *(?P<e>[+-]? *\d*(?:\.\d*)?))?`)
var str = `y=x+3.3X^-50+ 15x25.5 - 4x^+2x^2 +3*x-2.5+1.1
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}