package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:ID\s+)(\d{8})`)
var str = `... 12 ID 12345678 INDEPENDENT BOARD...
... 12 ID 87654321 (a.12(3)(b),45)...`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}