const regex = /(?:ID\s+)(\d{8})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:ID\\s+)(\\d{8})', 'g')
const str = `... 12 ID 12345678 INDEPENDENT BOARD...
... 12 ID 87654321 (a.12(3)(b),45)...`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}