$re = '/(?:ID\s+)(\d{8})/';
$str = '... 12 ID 12345678 INDEPENDENT BOARD...
... 12 ID 87654321 (a.12(3)(b),45)...';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);