re = /(?:ID\s+)(\d{8})/
str = '... 12 ID 12345678 INDEPENDENT BOARD...
... 12 ID 87654321 (a.12(3)(b),45)...'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end