// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?:ID\s+)(\d{8})").unwrap();
let string = "... 12 ID 12345678 INDEPENDENT BOARD...
... 12 ID 87654321 (a.12(3)(b),45)...";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}