#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?!^)(?=[A-Z])|(?<=\D)(?=\d)"
Local $sString = "IAmASentenceInCamelCaseWithNumbers500And1And37"
Local $sSubst = " "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)