const regex = /(?!^)(?=[A-Z])|(?<=\D)(?=\d)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?!^)(?=[A-Z])|(?<=\\D)(?=\\d)', 'gm')
const str = `IAmASentenceInCamelCaseWithNumbers500And1And37`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);