use strict;
my $str = 'IAmASentenceInCamelCaseWithNumbers500And1And37';
my $regex = qr/(?!^)(?=[A-Z])|(?<=\D)(?=\d)/mp;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";