$re = '/(?!^)(?=[A-Z])|(?<=\D)(?=\d)/m';
$str = 'IAmASentenceInCamelCaseWithNumbers500And1And37';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;