using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!^)(?=[A-Z])|(?<=\D)(?=\d)";
string substitution = @" ";
string input = @"IAmASentenceInCamelCaseWithNumbers500And1And37";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}