#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)agent-\d+-\d+:([a-zA-Z0-9!@#$&?()-.+,\/'<>_]*\s+)*(?<!(my phone number)\s*([a-zA-Z0-9!@#$&?()-.+,\/'<>_]*\s+){0,15}\S*)<PHONE_NUMBER>"
Local $sString = "you're very welcome. my phone number is on your caller id as well, <PHONE_NUMBER>.. agent-480000-486000:<PHONE_NUMBER> um, did you"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")