import Foundation
let pattern = ##"agent-\d+-\d+:([a-zA-Z0-9!@#$&?()-.+,\/'<>_]*\s+)*(?<!(my phone number)\s*([a-zA-Z0-9!@#$&?()-.+,\/'<>_]*\s+){0,15}\S*)<PHONE_NUMBER>"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"you're very welcome. my phone number is on your caller id as well, <PHONE_NUMBER>.. agent-480000-486000:<PHONE_NUMBER> um, did you"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)