const regex = /agent-\d+-\d+:([a-zA-Z0-9!@#$&?()-.+,\/'<>_]*\s+)*(?<!(my phone number)\s*([a-zA-Z0-9!@#$&?()-.+,\/'<>_]*\s+){0,15}\S*)<PHONE_NUMBER>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('agent-\\d+-\\d+:([a-zA-Z0-9!@#$&?()-.+,\\\/\'<>_]*\\s+)*(?<!(my phone number)\\s*([a-zA-Z0-9!@#$&?()-.+,\\\/\'<>_]*\\s+){0,15}\\S*)<PHONE_NUMBER>', 'gm')
const str = `you're very welcome. my phone number is on your caller id as well, <PHONE_NUMBER>.. agent-480000-486000:<PHONE_NUMBER> um, did you`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}