re = /agent-\d+-\d+:([a-zA-Z0-9!@#$&?()-.+,\/'<>_]*\s+)*(?<!(my phone number)\s*([a-zA-Z0-9!@#$&?()-.+,\/'<>_]*\s+){0,15}\S*)<PHONE_NUMBER>/m
str = 'you\'re very welcome. my phone number is on your caller id as well, <PHONE_NUMBER>.. agent-480000-486000:<PHONE_NUMBER> um, did you'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end