import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "agent-\\d+-\\d+:([a-zA-Z0-9!@#$&?()-.+,\\/'<>_]*\\s+)*(?<!(my phone number)\\s*([a-zA-Z0-9!@#$&?()-.+,\\/'<>_]*\\s+){0,15}\\S*)<PHONE_NUMBER>";
final String string = "you're very welcome. my phone number is on your caller id as well, <PHONE_NUMBER>.. agent-480000-486000:<PHONE_NUMBER> um, did you";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}