#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-zA-Z0-9_]+(?:\.[a-zA-Z0-9_]+)*$"
Local $sString = "abc" & @CRLF & _
"abc.xyz" & @CRLF & _
".abc" & @CRLF & _
"abc." & @CRLF & _
"ab..c" & @CRLF & _
"abc.xyz." & @CRLF & _
"abc.xyz.1" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")