using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-zA-Z0-9_]+(?:\.[a-zA-Z0-9_]+)*$";
string input = @"abc
abc.xyz
.abc
abc.
ab..c
abc.xyz.
abc.xyz.1
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}