re = /^[a-zA-Z0-9_]+(?:\.[a-zA-Z0-9_]+)*$/m
str = 'abc
abc.xyz
.abc
abc.
ab..c
abc.xyz.
abc.xyz.1
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end