#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!\S)(?:/[^/\s]+)+/\S+\.html\S*"
Local $sString = "need to convert /test/1.html into https://www.example.com/test/1.html" & @CRLF & _
"/test/1.html?test=1" & @CRLF & _
"" & @CRLF & _
"www.example.com/test/1.html" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")