import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\S)(?:/[^/\\s]+)+/\\S+\\.html\\S*";
final String string = "need to convert /test/1.html into https://www.example.com/test/1.html\n"
+ "/test/1.html?test=1\n\n"
+ "www.example.com/test/1.html\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}