re = /(?<!\S)(?:\/[^\/\s]+)+\/\S+\.html\S*/m
str = 'need to convert /test/1.html into https://www.example.com/test/1.html
/test/1.html?test=1
www.example.com/test/1.html
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end