using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\S)(?:/[^/\s]+)+/\S+\.html\S*";
string input = @"need to convert /test/1.html into https://www.example.com/test/1.html
/test/1.html?test=1
www.example.com/test/1.html
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}