$re = '~(?<!\S)(?:/[^/\s]+)+/\S+\.html\S*~m';
$str = 'need to convert /test/1.html into https://www.example.com/test/1.html
/test/1.html?test=1
www.example.com/test/1.html
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);