import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(\\?=)|)(?:(?:( |\\n|\\r\\n)|)(?:( |\\t)|)|)(?: |)(=)(?:[A-Za-z0-9].*|)(\\?(UTF|utf)\\-8\\?)([A-Za-z0-9]\\?)";
final String string = "?=\n"
+ " =?UTF-8?Q?\n"
+ "?=\n"
+ " =?UTF-8?Q?\n"
+ "=3D?UTF-8?Q?\n"
+ " =3D?UTF-8?Q?\n"
+ "=?UTF-8?Q?\n"
+ " =?UTF-8?Q?\n"
+ "?= =?UTF-8?Q?";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}