// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:(\?=)|)(?:(?:( |\n|\r\n)|)(?:( |\t)|)|)(?: |)(=)(?:[A-Za-z0-9].*|)(\?(UTF|utf)\-8\?)([A-Za-z0-9]\?)").unwrap();
let string = "?=
=?UTF-8?Q?
?=
=?UTF-8?Q?
=3D?UTF-8?Q?
=3D?UTF-8?Q?
=?UTF-8?Q?
=?UTF-8?Q?
?= =?UTF-8?Q?";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}