#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([v]?([0-9\.]+).*)"
Local $sString = "v0.0.0-rc1" & @CRLF & _
"v0.0.0" & @CRLF & _
"0.0.0" & @CRLF & _
"0.0.0rc1" & @CRLF & _
"test-0.0.0" & @CRLF & _
"r0.0.0"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")