// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([v]?([0-9\.]+).*)").unwrap();
let string = "v0.0.0-rc1
v0.0.0
0.0.0
0.0.0rc1
test-0.0.0
r0.0.0";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}