import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([v]?([0-9\\.]+).*)";
final String string = "v0.0.0-rc1\n"
+ "v0.0.0\n"
+ "0.0.0\n"
+ "0.0.0rc1\n"
+ "test-0.0.0\n"
+ "r0.0.0";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}