$re = '/^([v]?([0-9\.]+).*)/m';
$str = 'v0.0.0-rc1
v0.0.0
0.0.0
0.0.0rc1
test-0.0.0
r0.0.0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);