re = /^([v]?([0-9\.]+).*)/m
str = 'v0.0.0-rc1
v0.0.0
0.0.0
0.0.0rc1
test-0.0.0
r0.0.0'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end