import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "title=\"([^\\n\"]+)";
final String string = "<td class=\"vt\" title=\"\" ng-non-bindable=\"\" data-original-title=\"ITOM Control Board Major Alarm 4 Set\n"
+ "Message: User\n\n"
+ "<td class=\"vt\" title=\"ITOM Control Board Major Alarm 4 Set\n"
+ "Message: User";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}