// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)title="([^\n"]+)"#).unwrap();
let string = "<td class=\"vt\" title=\"\" ng-non-bindable=\"\" data-original-title=\"ITOM Control Board Major Alarm 4 Set
Message: User
<td class=\"vt\" title=\"ITOM Control Board Major Alarm 4 Set
Message: User";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}