re = /title="([^\n"]+)/m
str = '<td class="vt" title="" ng-non-bindable="" data-original-title="ITOM Control Board Major Alarm 4 Set
Message: User
<td class="vt" title="ITOM Control Board Major Alarm 4 Set
Message: User'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end