#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([0-9]{2}:[0-9]{2}:[0-9]{2})\s([\s\S]+?)\s([A-Z]+)\s\[([^]]+)\]\s(.*)"
Local $sString = "00:00:12 PARALLELS_DS_LOADER-28 DEBUG [standard] [SQL]SQL: select sum(airsupply) as sumyear from public.ipt_cumulative_annual_gas_supply where timeyear = '2021'"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")