// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([0-9]{2}:[0-9]{2}:[0-9]{2})\s([\s\S]+?)\s([A-Z]+)\s\[([^]]+)\]\s(.*)").unwrap();
let string = "00:00:12 PARALLELS_DS_LOADER-28 DEBUG [standard] [SQL]SQL: select sum(airsupply) as sumyear from public.ipt_cumulative_annual_gas_supply where timeyear = '2021'";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}