using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([0-9]{2}:[0-9]{2}:[0-9]{2})\s([\s\S]+?)\s([A-Z]+)\s\[([^]]+)\]\s(.*)";
string input = @"00:00:12 PARALLELS_DS_LOADER-28 DEBUG [standard] [SQL]SQL: select sum(airsupply) as sumyear from public.ipt_cumulative_annual_gas_supply where timeyear = '2021'";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}