package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([0-9]{2}:[0-9]{2}:[0-9]{2})\s([\s\S]+?)\s([A-Z]+)\s\[([^]]+)\]\s(.*)`)
var str = `00:00:12 PARALLELS_DS_LOADER-28 DEBUG [standard] [SQL]SQL: select sum(airsupply) as sumyear from public.ipt_cumulative_annual_gas_supply where timeyear = '2021'`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}