const regex = /^(?! )(?=.*?[a-z])(?=.*?[A-Z])(?=.*?\d)(?=.*?[[:punct:]])^[ -~]{8,255}(?<!\s)$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?! )(?=.*?[a-z])(?=.*?[A-Z])(?=.*?\\d)(?=.*?[[:punct:]])^[ -~]{8,255}(?<!\\s)$', 'mg')
const str = `Should pass:
aA12345678.
Should fail:
No punct:
aA123456
No lower:
A123456.
No upper:
a123456.
Too short:
aA1.
Too long:
aA01234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789.
Starts with a space:
aA12345678.
Ends with a space:
aA12345678. `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}