re = /^(?! )(?=.*?[a-z])(?=.*?[A-Z])(?=.*?\d)(?=.*?[[:punct:]])^[ -~]{8,255}(?<!\s)$/m
str = 'Should pass:
aA12345678.
Should fail:
No punct:
aA123456
No lower:
A123456.
No upper:
a123456.
Too short:
aA1.
Too long:
aA01234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789.
Starts with a space:
aA12345678.
Ends with a space:
aA12345678. '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end