using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^`(另类|基础|应用) .{1,10}` (从(Mongo|MDA|CSR|东财|SnP|Google Sheet)导入|计算|(DEV|PROD)导出到(PG|Arango|ES|MDA)|导出到Google Sheet): ([^ ]+\.[^ ]+)(, [^ ]+\.[^ ]+)*$";
string input = @"`另类 排污许可` 从Google Sheet导入: ref.ref_exceed_pollutant_type
`另类 SAMR` 从Google Sheet导入: pds.source_samr_punishment_manual_reviewed
`另类 SAMR` 计算: pds.source_samr_punishment, pds.source_samr_punishment_to_review
`另类 SAMR` DEV导出到PG: ads.esg_alt_penalty_samr_all_prov_stats
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}