use strict;
my $str = '`另类 排污许可` 从Google Sheet导入: ref.ref_exceed_pollutant_type
`另类 SAMR` 从Google Sheet导入: pds.source_samr_punishment_manual_reviewed
`另类 SAMR` 计算: pds.source_samr_punishment, pds.source_samr_punishment_to_review
`另类 SAMR` DEV导出到PG: ads.esg_alt_penalty_samr_all_prov_stats
';
my $regex = qr/^`(另类|基础|应用) .{1,10}` (从(Mongo|MDA|CSR|东财|SnP|Google Sheet)导入|计算|(DEV|PROD)导出到(PG|Arango|ES|MDA)|导出到Google Sheet): ([^ ]+\.[^ ]+)(, [^ ]+\.[^ ]+)*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}