import re
regex = re.compile(r"^`(另类|基础|应用) .{1,10}` (从(Mongo|MDA|CSR|东财|SnP|Google Sheet)导入|计算|(DEV|PROD)导出到(PG|Arango|ES|MDA)|导出到Google Sheet): ([^ ]+\.[^ ]+)(, [^ ]+\.[^ ]+)*$", flags=re.MULTILINE)
test_str = ("`另类 排污许可` 从Google Sheet导入: ref.ref_exceed_pollutant_type\n"
"`另类 SAMR` 从Google Sheet导入: pds.source_samr_punishment_manual_reviewed\n"
"`另类 SAMR` 计算: pds.source_samr_punishment, pds.source_samr_punishment_to_review\n"
"`另类 SAMR` DEV导出到PG: ads.esg_alt_penalty_samr_all_prov_stats\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")