#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(?:[a-z]{2}\d-)?[a-z]{2}-[a-z]-"
Local $sString = "qq8-qq-q-anything" & @CRLF & _
"qq-q-anything" & @CRLF & _
"888-q-anything" & @CRLF & _
"anything-qq-q-anything"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")