package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^(?:[a-z]{2}\d-)?[a-z]{2}-[a-z]-`)
var str = `qq8-qq-q-anything
qq-q-anything
888-q-anything
anything-qq-q-anything`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}