// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^(?:[a-z]{2}\d-)?[a-z]{2}-[a-z]-").unwrap();
let string = "qq8-qq-q-anything
qq-q-anything
888-q-anything
anything-qq-q-anything";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}